Jump to content
  • 0

Monero - Low H/s


Go to solution Solved by Hashvault,

Question

Okay,

On to next question.

Is using XMRIG on an old laptop worth the cycles used.

I'm running Slackware 14.2 on 2 servers. x86_64 Intel(R) Xeon(R) CPU E3-1230 v5 @ 3.40GHz GenuineIntel GNU/Linux

One is RAW (No VPS running) just OS and XMRIG, 216 H/s max.

Another is a VPS, running on identical hardware/OS, XMRIG 128 H/s max.

Then I got this old Compaq x86_64 Intel(R) Core(TM)2 Duo CPU     T8100  @ 2.10GHz GenuineIntel GNU/Linux producing 26.9 H/s

And a new Acer running a VPS on x86_64 Intel(R) Core(TM) i7-5500U CPU @ 2.40GHz GenuineIntel GNU/Linux doing 23.6 H/s

Does the 2 laptops contribute, or am I wasting CPU ?

The 2 servers are located in Denmark, and the 2 laptops in Thailand.

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1
  • Solution

You should run 4 threads.

Each thread consumes 2 mb of L3 cache memory, so max you should have L3\2 threads.

And huge pages, yes.

You can use this something like this:

#!/usr/bin/env bash
 
script=`basename "$0"`
HPS=`grep Hugepagesize /proc/meminfo | awk -F" " {'print $2'}`
NC=`grep -c processor /proc/cpuinfo`
NHP=$(($(($NC*2200/$HPS))+1))
case $@ in
 
        enable)
                echo $NHP > /proc/sys/vm/nr_hugepages
                ulimit -l $(($NHP * $HPS))
                echo "Huge pages enabled"
                ;;
 
        disable)
                echo 0 > /proc/sys/vm/nr_hugepages
                echo "Huge pages disabled"
                ;;
 
        *)
                echo -e "Usage: \n$script enable - Enabling Huge Pages\n$script disable - Disabling Huge Pages"
                ;;
 
esac

 

You can enable without any recompilation.

Link to post
Share on other sites
  • 0

Enter your hashrates here, it will calculate potential profit (not including electricity cost, HW wear or other expenses) https://www.cryptunit.com

 

As you will see, your 25H/s rigs will mine practically nothing.

 

That being said, your i7 should mine faster. Maybe your configs are not done correctly? Or you are not fully utilizing CPU power potential.

 

In XMRig you have to enable cores which are allowed to mine. Check cpu.txt


_______________
Wor3d
Hashvault [SK/CZ] Support Team

Don't forget to join our forum at hashvault.pro and join our Discord Server here.

Link to post
Share on other sites
  • 0

Even with 8 threads,the i7 only does 108.6 H/s average. I don't think I can enable "huge pages" without a kernel recompile.

This is what I get when starting XMRIG:

$ start-xmrig.sh                 
 * VERSIONS:     XMRig/2.6.2 libuv/1.20.3 gcc/5.5.0
 * CPU:          Intel(R) Xeon(R) CPU E3-1230 v5 @ 3.40GHz (1) x64 AES-NI
 * CPU L2/L3:    1.0 MB/8.0 MB
 * THREADS:      8, cryptonight, av=0, donate=1%
 * POOL #1:      pool.monero.hashvault.pro:5555
 * COMMANDS:     hashrate, pause, resume
[2018-05-11 19:26:09] READY (CPU) threads 8(8) huge pages 0/8 0% memory 16.0 MB

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...