Jump to content
Mr Bee

Huge Pages - final tweaks

Recommended Posts

 

Dear Community, 

 

I would like to have these Hugepages supported now :-)
I am thus referring to this thread here, which seems to be closed. I have tried the following to enable hugepages AND get them working until 1 GB. 
See me output:

Thanks so far!
Bee

***

Question: Why is HUGEpages 1 GIg not available? 
How do I set the value correct?

My output:

sysctl -a | grep hugep
sysctl: error reading key 'net.ipv6.conf.all.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.default.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.lo.stable_secret': I/O error
vm.nr_hugepages = 2349
vm.nr_hugepages_mempolicy = 2349
vm.nr_overcommit_hugepages = 0

*** and in xmrig *** 

ABOUT        XMRig/6.7.0 gcc/9.3.0
 * LIBS         libuv/1.38.1 OpenSSL/1.1.1i hwloc/2.2.0
 * HUGE PAGES   supported
 * 1GB PAGES    unavailable
 * CPU          Intel(R) Xeon(R) CPU E3-1280 V2 @ 3.60GHz (1) 64-bit AES
                L2:1.0 MB L3:8.0 MB 4C/8T NUMA:1
 * MEMORY       3.2/15.6 GB (21%)
 * DONATE       1%
 * ASSEMBLY     auto:intel
 * POOL #1      pool.hashvault.pro:3333 algo auto
 * COMMANDS     hashrate, pause, resume, results, connection
 * OPENCL       disabled
 * CUDA         disabled

 

Share this post


Link to post
Share on other sites

Update:
Having applied the Script from the thread linked to above, I get another outcome.
Is that as it is supposed to be??

Thanks again
Bee

alpinehost:/home/alp# chown root /usr/share/hugepages.sh 
alpinehost:/home/alp# /usr/share/./hugepages.sh enable
Huge pages enabled
alpinehost:/home/alp# sysctl -a | grep hugep
sysctl: error reading key 'net.ipv6.conf.all.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.default.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.eth0.stable_secret': I/O error
sysctl: error reading key 'net.ipv6.conf.lo.stable_secret': I/O error
vm.nr_hugepages = 9
vm.nr_hugepages_mempolicy = 9
vm.nr_overcommit_hugepages = 0
alpinehost:/home/alp# 

The vm.nr_hugepages changed dramatically. What does it mean anyways?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...